Go Back  ZDriver.com > Cars > 350Z (Z33) Forums
Sensors all bad!? Bank1 sensor 1&2 + bank 2 sensor 2?? >

Sensors all bad!? Bank1 sensor 1&2 + bank 2 sensor 2??

350Z (Z33) Forums Dedicated to 2003 + ZCars otherwize known as the Z33's

Sensors all bad!? Bank1 sensor 1&2 + bank 2 sensor 2??

Old 05-08-2012, 07:38 AM
  #1  
Registered User
Thread Starter
 
Join Date: May 2012
Posts: 10
Sensors all bad!? Bank1 sensor 1&2 + bank 2 sensor 2??

hey mates, I jsut bought a used 350z radoster 2004. it needs a little work but a i got it very cheap.
I ran the auto zone codes and it came back with these codes:

P0138
P1148
P0158
P1276

this car has a really cheap aftermarket air filter on it but no other mods.

these codes indicate that both bank 1 sensors need replacing and bank 2 sensor 2.

could it be that all three snesors are indeed bad or could one bad sensor throw the others?

thanks so much for your help!
nick731 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SkillZ
FS: 300ZX (84-89)
0
08-24-2011 07:35 AM
jaredjmoore89
300ZX (Z32) Performance / Technical
2
11-29-2008 08:09 PM
scorpionp54
280ZX (S130) Forums
22
10-06-2008 11:47 AM
SandW
300ZX (Z32) Performance / Technical
12
10-13-2006 04:10 PM
Seraphic
300ZX (Z32) Performance / Technical
15
07-13-2005 09:22 PM


Thread Tools
Search this Thread
Quick Reply: Sensors all bad!? Bank1 sensor 1&2 + bank 2 sensor 2??


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.