240Z, 260Z, 280Z Performance / Technical Discussions related to performance motor enhancements, upgrades.

Fuel injectors not recieving power!

Old 04-24-2013, 05:49 PM
  #1  
Registered User
Thread Starter
 
Join Date: Mar 2013
Posts: 6
Fuel injectors not recieving power!

I think this may be the culprit, what's it look like to you more informed people? This is my first Z so any input would be awesome.

Fuel pump works, fuel gets all the way up to the rail, holds pressure but injectors do not open! Driving me nuts.

Name:  photo-8_zps0a502f2a.jpg
Views: 112
Size:  189.1 KB

and the ride.

Name:  181003_10152639612460596_2029727625_n_zpsb7e17cc9.jpg
Views: 130
Size:  113.6 KB
Solhaven is offline  
Old 04-24-2013, 06:56 PM
  #2  
The Good Twin
 
NismoPick's Avatar
 
Join Date: Aug 2005
Location: Wild Wild West, UTAH!
Posts: 20,616
Welcome to ZDriver and beautiful S30!

Have you checked the fusible links?
NismoPick is offline  
Old 04-24-2013, 07:29 PM
  #3  
Registered User
Thread Starter
 
Join Date: Mar 2013
Posts: 6
All 4 of the fusible links have power running to them!
Solhaven is offline  
Old 04-24-2013, 10:07 PM
  #4  
Intrawebz Wizard
 
BlueKitsune's Avatar
 
Join Date: Feb 2009
Location: Vernal, UT
Posts: 3,176
Under the window washer fluid tank theres a silver little box like thing with a wired connector off the bottom. Thats a dropping resistor for the injectors so they don't get full battery power. Check the connection on that and make sure the wires haven't broken off from it as well.

Its kinda common for the wiring to break off of it.
BlueKitsune is offline  
Old 04-25-2013, 05:44 AM
  #5  
Registered User
Thread Starter
 
Join Date: Mar 2013
Posts: 6
Ok I'll be sure to do that! Anyone know what the wires from my first picture go to?
Solhaven is offline  
Old 04-25-2013, 08:30 AM
  #6  
Registered User
 
Skully's Avatar
 
Join Date: Feb 2002
Location: Saskatoon, SK
Posts: 2,886
Originally Posted by Solhaven View Post
Ok I'll be sure to do that! Anyone know what the wires from my first picture go to?
Maybe altitude switch? That is the only thing I can see in cali models.
You can see here
Skully is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dan121
240Z, 260Z, 280Z (S30) Forums
4
01-28-2012 11:31 AM
mwest300zx
300ZX (Z32) Forums
6
01-08-2012 11:38 AM
hardenstine
300ZX (Z32) Performance / Technical
9
01-29-2011 09:47 AM
ern
300ZX (Z31) Performance / Technical
1
07-19-2010 09:58 AM
TeamRonin
300ZX (Z31) Forums
9
10-06-2009 10:24 PM


Thread Tools
Search this Thread
Quick Reply: Fuel injectors not recieving power!


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.