Site Feedback and Suggestions If you have any suggestions or want to see something voice your opinion in here.

300zx wont start

Old 04-19-2010, 05:47 PM
  #1  
Registered User
Thread Starter
 
Join Date: Apr 2010
Posts: 5
300zx wont start

i have a 1990 300zx and i was driving around the block and it started 2 heat up and smoke was coming out from under the hood on the passenger side of the car and it just shut off in mid drive. i think i had a leak in one of my radiator hoses cuz it was dry when i opened it up but my car still wont start. i changed out the fuse box under the hood because one of the females was burnt up but still nothing. my stereo wont turn on, my windows dont roll up, a/c...nothing! the only things that work are my lights and power seats. any suggestions?
SharkAttack22 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Zrider
300ZX (Z32) Forums
1
01-02-2014 06:12 AM
plainwhiteZ
300ZX (Z32) Forums
0
05-11-2013 12:20 PM
moorebl
280ZX (S130) Forums
2
04-14-2011 03:28 PM
SharkAttack22
300ZX (Z32) Forums
5
05-11-2010 05:52 PM
tc300zx
300ZX (Z32) Performance / Technical
20
05-23-2007 02:47 AM


Thread Tools
Search this Thread
Quick Reply: 300zx wont start


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.