300ZX (Z31) Performance / Technical Discussions related to Turbo charging, Supercharging, Engine, ECU, exhaust, and etc. performance enhancements and Techical related.

Z31 havaing spark issues/ fuel pump not turning on

Old 06-14-2016, 01:17 PM
  #1  
Registered User
Thread Starter
 
Join Date: Feb 2016
Posts: 4
Question Z31 havaing spark issues/ fuel pump not turning on

So I have a 1987 300zx that was originaly N/A I swapped a running vg30 Turbo into it from a 1985 keeping the harness and wiring with the motor when I did the swap. I also fried the ecu I'm pretty sure with some spark that happened when I first turned the key! I keep thinking maybe some sort of relay I cant find is fried somewhere too! right now I have an ecu from an 1986 turbo and I get spark but shitty spark, the fuel pump does not turn on. still. I wired it up to a switch temporarily, when I turn the key it starts but sounds like it is misfiring and when I use the timing light to test the spark coming from the coil and different wires I only get spark one a couple cylinders. I tried swapping out the distributors and coils from the parts car, but what are the chances they would both randomly stop working?? there is also this little thing above the coil that has a clip and it is a resistor I believe it was actually getting hot I'm wondering if that thing could be messing something up. Also, I spun my distributor with t he key on and I only hear two clicks from the injectors is that normal, cause I thought it should click six times maybe since there are six, but with both distributors it is same thing it clicks twice and runs on like 2 cylinders, sounds like a motor cycle lol. well any advice or ideas would be sweet! thanks for reading.
fairlady_lea is offline  
Old 06-15-2016, 07:19 AM
  #2  
The Good Twin
 
NismoPick's Avatar
 
Join Date: Aug 2005
Location: Wild Wild West, UTAH!
Posts: 20,616
NismoPick is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
DeathByNissan55
240Z, 260Z, 280Z (S30) Forums
5
06-13-2014 10:53 AM
Fairladyz1990AF
300ZX (Z32) Forums
7
04-24-2014 04:15 PM
Doomfinger
280ZX Performance / Technical
7
12-06-2012 01:51 PM
lilmike81888
300ZX (Z32) Performance / Technical
14
11-07-2011 09:14 AM
sameerb1
280ZX (S130) Forums
6
03-20-2011 05:21 AM


Thread Tools
Search this Thread
Quick Reply: Z31 havaing spark issues/ fuel pump not turning on


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.