300ZX (Z31) Performance / Technical Discussions related to Turbo charging, Supercharging, Engine, ECU, exhaust, and etc. performance enhancements and Techical related.

Oil Pressure Troubleshooting

Old 02-27-2017, 01:35 PM
  #1  
Registered User
Thread Starter
 
Join Date: Feb 2017
Posts: 1
Oil Pressure Troubleshooting

Hello everyone,

I've got an 87 Z31 NA I picked up recently that always just shows no oil pressure. I picked up a replacement sender unit, did a full oil change with a synthetic blend, cleaned the connector, fired her up aaand...still shows no oil pressure.

Just hoping someone can point me in the right direction of what I should look at next, is it typical for the gauge itself to fail? The car drives just fine, so I'm pretty sure it's not a case of actually having no oil pressure!
hpiz31 is offline  
Old 02-28-2017, 12:30 PM
  #2  
The Good Twin
 
NismoPick's Avatar
 
Join Date: Aug 2005
Location: Wild Wild West, UTAH!
Posts: 20,616
Welcome to ZDriver!

Check the wiring. And make sure you've downloaded the FSM:
Z31 Factory Service Manuals
NismoPick is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
frawleyfly
280ZX (S130) Forums
1
09-29-2013 08:24 PM
Duck Ryder
280ZX (S130) Forums
6
04-20-2012 04:39 PM
duowing
300ZX (Z31) Forums
15
03-31-2009 06:56 AM
duowing
280ZX (S130) Forums
46
06-14-2006 07:09 PM
BlackbirdPilot
240Z, 260Z, 280Z Performance / Technical
0
03-23-2006 12:03 AM


Thread Tools
Search this Thread
Quick Reply: Oil Pressure Troubleshooting


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.