300ZX (Z31) Performance / Technical Discussions related to Turbo charging, Supercharging, Engine, ECU, exhaust, and etc. performance enhancements and Techical related.

Help 300zx 3.0 na fuel pump problem?

Old 04-29-2018, 08:48 AM
  #1  
Registered User
Thread Starter
 
Join Date: Apr 2018
Posts: 2
Help 300zx 3.0 na fuel pump problem?

I just bought an 85 300zx na. Doesnít run. Guy said he thought it was fuel pump and I agreed. So I took the fuel tank out and the fuel pump out of that and it was fine put power directly into it and it turned on. Then I thought maybe it was just a relay. Switched out the relay with others that were good and it didnít change anything either. The fuel pump still wonít turn on with the turn of the key. Does anyone know what my next step from here should be? I have the dash apart and I can see all the wires under the drivers side. Is there any way to tell where my problem is?
Camron is offline  
Old 05-07-2018, 09:09 PM
  #2  
Registered User
 
Join Date: May 2018
Location: Northern CA
Posts: 4
Start at the relay.

Check to make sure that everything from relay to pump is working correctly. In other words start by checking to see if the relay gets power (test with meter but you will also hear the audible click) when the ignition is turned ona and looses power when ignition is turned off. If the relay is working off the ignition then you problem is between relay and fuel pump. Use your twelve volt power source to test the relay and verify that putting power to the relay operates the fuel pump. If all is well between relay and pump just not getting power to relay when the ignition is turned on then start tracing from relay back to ignition. If you need a wire diagram I have one for a 88 and have a service manual for a 86 so between the 2 I could probably shoot you some pictures of the wiring diagrams and fuel pump diagrams. Also make sure to check all grounding to make sure it isnt just a loose ground or one getting a bad connection due to corrosion. Good luck!
DrivenYFZ is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
WylieCoyote88
Site Brainstorming
1
08-06-2017 10:57 AM
sameerb1
280ZX (S130) Forums
6
03-20-2011 05:21 AM
ern
300ZX (Z31) Performance / Technical
2
10-20-2006 07:01 AM
Creator
240Z, 260Z, 280Z (S30) Forums
6
10-17-2002 10:16 AM
280ZXtreme
240Z, 260Z, 280Z (S30) Forums
1
04-10-2001 07:00 AM


Thread Tools
Search this Thread
Quick Reply: Help 300zx 3.0 na fuel pump problem?


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.