Go Back  ZDriver.com > Cars > 300ZX (Z31) Forums
Speedometer cable >

Speedometer cable

300ZX (Z31) Forums Dedicated to 84-89 ZCars otherwize known as the Z31's

Speedometer cable

Old 07-29-2018, 08:09 AM
  #1  
Registered User
Thread Starter
 
Join Date: Mar 2018
Posts: 4
Speedometer cable

Hey guys, new poster to the forum. Long time Nissan 300zx owner. I have an 86 GLL NT manual analog dash. I have decided to fix a long time problem to get the car safetied. In my reading it appears my speed sensor and oil in the speedometer cable may have been the problem. I replaced the speed sensor as suggested. I also checked the back of the gauge cluster for fluid. My question is it looks likes there is grease in the cable. It was all over the back of the mount for the cable to the dash as well. Is it supposed to be greased or is it gummed transmission fluid? I'm wanting to put it back together but need to know if I need to re grease it again. I wiped it out thinking it didn't belong. Thanks guys.
LloydChristmas is offline  
Old 07-29-2018, 10:26 PM
  #2  
The Good Twin
 
NismoPick's Avatar
 
Join Date: Aug 2005
Location: Wild Wild West, UTAH!
Posts: 20,616
Yes there should be grease on the metal cable... needs lube as it spins
NismoPick is offline  
Old 07-30-2018, 04:05 PM
  #3  
Registered User
Thread Starter
 
Join Date: Mar 2018
Posts: 4
Perfect, thanks! Now I just have to get it back together lol.
LloydChristmas is offline  
Old 07-31-2018, 11:52 AM
  #4  
Registered User
Thread Starter
 
Join Date: Mar 2018
Posts: 4
So to go a bit farther, I hooked the speedometer cable back up after replacing the speed sensor. When I tried running the car the speedometer would jump all over and settle back in. Could it be the cable? When I pulled the dash apart there was no oil on the back of the gauges. Just grease. Any suggestions on where to look next? I don't want to put it back together to have to rip it apart again lol

thanks!
LloydChristmas is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
gixxr_06
280ZX (S130) Forums
2
08-10-2012 05:02 PM
Aldakoopa
300ZX (Z31) Forums
8
11-07-2011 06:17 PM
ADukesIII
300ZX (Z31) Performance / Technical
6
08-20-2007 01:46 PM
WildmaN
280ZX (S130) Forums
1
05-31-2007 10:32 AM
ADukesIII
300ZX (Z31) Forums
4
05-23-2007 10:01 PM


Thread Tools
Search this Thread
Quick Reply: Speedometer cable


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.