300ZX (Z32) Forums Dedicated to 90-96 ZCars otherwize known as the Z32's

No oil pressure/ticking valves

Old 12-17-2016, 11:02 PM
  #1  
Registered User
Thread Starter
 
Join Date: Dec 2016
Posts: 2
No oil pressure/ticking valves

Ok guys I have a 94 300zx NA, I have an issue with my oil pressure it's reading at 0 psi and my passenger valve is ticking a lot I spun out on the highway as I go to turn it back on it turns over but now has no oil pressure and is ticking car has 140k miles kid I bought it from states that it has 292 cams and walboro fuel pump and is mild built "just got the car"
James Nguyen is offline  
Old 12-18-2016, 06:33 PM
  #2  
JSM
Registered User
 
Join Date: May 2010
Location: Orlando, FL
Posts: 114
Forgive me but you did check the oil to make sure you have enough?
JSM is offline  
Old 12-18-2016, 07:23 PM
  #3  
Registered User
Thread Starter
 
Join Date: Dec 2016
Posts: 2
Yes, that was the first thing that ive checked. I have checked the oil pressure sending unit plugs and lines made sure apl of the lines were correct but even if it was the oil pressure sending unit, that wouldnt cause the ticking as if there was no oil in the head...
James Nguyen is offline  
Old 12-18-2016, 08:03 PM
  #4  
JSM
Registered User
 
Join Date: May 2010
Location: Orlando, FL
Posts: 114
I wonder if your oil pressure valve got stuck. The oil filter relief valve is pressed into the block where the oil filter mounts. The valve opens to prevent pressure build-up, both in the oil filter and in the block. A faulty valve can cause high oil pressure if stuck closed. It can cause low oil pressure if it is stuck open or if the ball bearing is damaged. It is always best to replace a faulty valve rather than trying to repair it.

TwinTurbo.NET: Nissan 300ZX forum

Or somehow you spin caused some sludge to get sucked up into your oil pickup screen.
JSM is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RETICON
280ZX Performance / Technical
12
11-01-2012 03:49 PM
RichardZ32
300ZX (Z32) Performance / Technical
4
09-15-2007 06:55 PM
ArmyZ
300ZX (Z32) Performance / Technical
5
09-03-2005 12:33 PM
allmotor300z
300ZX (Z32) Performance / Technical
20
03-11-2005 10:32 PM
Eliott
300ZX (Z31) Forums
7
06-23-2001 11:30 PM


Thread Tools
Search this Thread
Quick Reply: No oil pressure/ticking valves


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.