Engine Misfire - ZDriver.com

Go Back  ZDriver.com > Cars > 300ZX (Z32) Forums
Engine Misfire >

Engine Misfire

300ZX (Z32) Forums Dedicated to 90-96 ZCars otherwize known as the Z32's

Engine Misfire

Old 01-16-2018, 12:48 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jan 2012
Location: SD
Posts: 13
Engine Misfire

So my 93 300zx check engine light came on recently. After this light appeared my car starting having irregular idle and loss of power. I figured it was some sort of misfire. So what I did was disconnect the plug that is connected to the coils while the car was on in order to see if a cylinder wasnt working. Sure enough when I disconnected the middle coil from the passenger side there was no change in the idle suggesting that cylinder is bad. So I swapped spark plugs and then I swapped coils and still the same cylinder doesnt work. Any suggestions on what the problem could be? Im thinking either fuel injector or the wires connecting to the coil are not supply current (I just dont know how to test this or replace the wires).
Young.gio is offline  
Old 01-18-2018, 10:07 AM
  #2  
The Good Twin
 
NismoPick's Avatar
 
Join Date: Aug 2005
Location: Wild Wild West, UTAH!
Posts: 20,616
It's very common for the injectors to die on the Z32. (sad face). If swapping coils didn't change anything, then it's either a dead injector, or bad compression.
NismoPick is offline  
Old 02-24-2018, 06:01 AM
  #3  
Registered User
 
Cobalt60's Avatar
 
Join Date: Dec 2017
Posts: 28
I didn't see where you checked the engine codes to find out what caused the check engine light. That would provide good information before you get too far down the rabbit hole.

There are lots of things that can cause a rough idle and loss of power. Find out what caused the CEL first.
Cobalt60 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ZOMBIEEATER
300ZX (Z32) Performance / Technical
27
08-20-2006 05:19 PM
defreesw
240Z, 260Z, 280Z Performance / Technical
6
11-01-2004 08:12 AM
MetalTear17
300ZX (Z32) Performance / Technical
5
08-04-2004 05:57 AM
iksteh
240Z, 260Z, 280Z (S30) Forums
5
11-11-2002 02:50 AM
tyco1983
240Z, 260Z, 280Z (S30) Forums
1
03-26-2002 11:40 PM


Thread Tools
Search this Thread
Quick Reply: Engine Misfire


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.