300ZX (Z31) Forums Dedicated to 84-89 ZCars otherwize known as the Z31's

Clutch stuck down

Old 07-04-2016, 11:15 AM
  #1  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 14
Angry Clutch stuck down

Ok so I just bought my second z31, a 1984 n/a which the guy didnt know if it was running or not, but i got it to fire up. So the only visible problem with it right now is the clutch feels like it is not connected to anything. It will stay up, but with any force on it it springs down to the floor and stays there. This is a picture I took of what I think is the problem, but I couldnt find anything on the internet about fixing it so I'm hoping the good people of ZDriver can help me out. I want to know how to fix it, or what the problem is so I can google it. Cheers!

Last edited by 86turbo; 07-04-2016 at 12:14 PM.
86turbo is offline  
Old 07-04-2016, 11:15 AM
  #2  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 14
Screenshot by Lightshot thats the picture, I think the thing circled in blue is supposed to be bolted onto the clutch pedal, because it looks like it was at one point. I have no idea how to fix it. Let me know, cheers
86turbo is offline  
Old 07-04-2016, 12:13 PM
  #3  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 14

86turbo is offline  
Old 07-05-2016, 07:41 AM
  #4  
Registered User
 
Skully's Avatar
 
Join Date: Feb 2002
Location: Saskatoon, SK
Posts: 2,885
Pretty sure, that is not bolted where you think it is. Looks to be just a clutch switch, and its missing stopper on the clutch pedal, to push up against the switch. You either have crappy slave/master, need bleeding, or something in the clutch mechanism. I would start with simple fluid check, visual leak check, and try bleeding. Make sure you can feel resistance on the fork, and your slave isn't pushed out all the way (mechanical issue with fork).

Last edited by Skully; 07-05-2016 at 07:45 AM.
Skully is offline  
Old 09-01-2016, 08:26 PM
  #5  
Registered User
 
Join Date: Nov 2015
Location: Pennsylvania
Posts: 5
Originally Posted by 86turbo View Post
Ok so I just bought my second z31, a 1984 n/a which the guy didnt know if it was running or not, but i got it to fire up. So the only visible problem with it right now is the clutch feels like it is not connected to anything. It will stay up, but with any force on it it springs down to the floor and stays there. This is a picture I took of what I think is the problem, but I couldnt find anything on the internet about fixing it so I'm hoping the good people of ZDriver can help me out. I want to know how to fix it, or what the problem is so I can google it. Cheers!
I had a similar issue and a new clutch slave cylinder fixed it for me
84zxturbo is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rubytuesday
300ZX (Z32) Forums
2
06-25-2014 10:49 PM
Carson B
300ZX (Z32) Forums
1
06-01-2014 05:25 PM
raps101
350Z (Z33) Forums
19
01-31-2012 10:01 AM
divethat
300ZX (Z31) Forums
0
08-07-2003 03:12 PM
zpeedrazer
240Z, 260Z, 280Z (S30) Forums
0
12-08-2001 04:46 PM


Thread Tools
Search this Thread
Quick Reply: Clutch stuck down


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.