1986 300ZX not starting - ZDriver.com


300ZX (Z31) Forums Dedicated to 84-89 ZCars otherwize known as the Z31's

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 10-12-2017, 06:30 AM   #1
Registered User
Thread Starter
 
Join Date: Oct 2017
Posts: 3
1986 300ZX not starting

I have a 1986 300 ZX non-turbo that will not start. I have had it since July 2017. It has been running fine until 2 weekends ago. Upon starting it was running really rough with black smoke coming out of the exhaust. I am assumed it was running rich. After I turned it off it would not start. I waited several hours tried again and it started, still running rough. On the ride home it suddenly started running normal. Drove it last week, went to work Friday and it hasn't started since. I ran diagnosis on ECU. It gave me codes 12, 13, 21, and 41. I replaced the Air Flow Sensor last night. It first tried to start, then nothing. It is now showing 23, 31, and 41. It has plenty of fuel. You can smell it. It has spark at the distributor. Thanks for your input.
jdkirkham1 is offline   Reply With Quote
Old 10-12-2017, 05:22 PM   #2
Registered User
 
zxguy1986's Avatar
 
Join Date: Aug 2013
Posts: 1,054
Locate your air regulator and check the operation of the 2 solenoids it houses.One is idle-up reg, important for holding idle. You test them by removing, applying a charge and listening for the little click of the solenoid inside. Hard to find replacements unless you buy the whole regulator from a recycler. They are available Check out your FSM XenonZcar.com Z31 1984-1989 300zx Reference and maybe Car-Part.com--Used Auto Parts Market for a nearby recycler. Report back, please. Gracias.
zxguy1986 is offline   Reply With Quote
Old 10-12-2017, 06:50 PM   #3
Registered User
 
Join Date: Nov 2013
Location: east KS
Posts: 217
By your description its flooded after 5 sec FI starts to overfuel
best to pull the plugs carefully dry them or replace ,careful with spark ,coil discon. Crank the fuel out the sp holes ,I usually discon the injector conections start on carb spray if needed
86tcoupe is offline   Reply With Quote
Old 10-13-2017, 09:46 AM   #4
Registered User
Thread Starter
 
Join Date: Oct 2017
Posts: 3
86 300zx

Thanks for your input. I will be looking at it this weekend. I will let you know what turns out.
jdkirkham1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
86 300zx not starting jdkirkham1 Site Brainstorming 1 10-16-2017 02:10 PM
78 280z not cranking. not starting. please help 3d_Ryan 240Z, 260Z, 280Z (S30) Forums 6 05-22-2016 06:23 PM
1986 300ZX (Z31) starting problems... cooch85 300ZX (Z32) Forums 2 03-30-2016 07:48 AM
1988 300zx not starting Micah.Crews 300ZX (Z31) Forums 1 03-14-2013 10:30 PM
1986 starting problems bigdoggin 300ZX (Z31) Performance / Technical 2 04-10-2012 09:17 AM


Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 10:10 AM.


Copyright 2000 - 2014 ZDRIVER.COM All Rights Reserved.