240Z, 260Z, 280Z Performance / Technical Discussions related to performance motor enhancements, upgrades.

New Member from WA needing some expert advice

Old 03-18-2013, 08:52 PM
  #1  
Registered User
Thread Starter
 
Join Date: Mar 2013
Posts: 1
New Member from WA needing some expert advice

Whats up guys. Names Callon, just picked up my second 280z a couple days ago. I had a 77 a couple years ago and kept kicking myself for getting rid of it... so i got a new one. 78 blue 5 speed swap!

Anyways... I usually just stalk forums but I've got a problem and decided to post here since i'm stumped.

Since I got the Z its always been running a little rich, when I looked at it a couple days before owning it, it was running fine- no problems. But in between that and when I got it the previous messed with the idle air screw in hopes to fix a high idle problem he was having (previous owner being a friend of mine). Ever since it has been running a little on the rich side. The high idle problem was quickly resolved with a lube of the throttle linkages but one day the car just got a little worse and started plummeting out pretty thick white smoke.

So far I've replaced the water temp switch because it was in pretty bad shape and they are cheap, i've unplugged the cold start valve in hopes to see if it was just the sensor, I even removed it and ran it without the valve entirely and barely even noticed it leaning out. Its getting spark. I'm planning on checking the pressure tomorrow, its just driving me crazy because it was running fine until the previous owner messed with the idler air switch I forgot to mention that since I've returned it to its 6 1/2 turns out from full rich. I'll keep diagnosing but I wanted to see if anyone on here lives in the greater Bellingham area and could give me a hand or had any ideas of what to check. It seems like something really dumb and easy but its stumping me.

btw I've downloaded the factory service manual and have been poking at the fuel injection section with no real direction... will keep doing research.
Callon Bigger is offline  
Old 03-28-2013, 09:34 AM
  #2  
I have a present for you...
 
theramz's Avatar
 
Join Date: Mar 2003
Location: dayton, nevada usa
Posts: 1,661
Check for signs of a blown headgasket= white smoke from coolant.
theramz is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Z31_Owner
300ZX (Z31) Forums
6
03-03-2015 05:37 PM
escapingfate
300ZX (Z32) Forums
0
08-14-2011 06:17 PM
Cloudxs
300ZX (Z32) Performance / Technical
20
05-26-2009 05:24 PM
woodyracing
280ZX (S130) Forums
8
08-17-2007 11:01 PM
tah
240Z, 260Z, 280Z (S30) Forums
10
01-25-2005 12:06 PM


Thread Tools
Search this Thread
Quick Reply: New Member from WA needing some expert advice


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.