AFM problems - ZDriver.com


240Z, 260Z, 280Z Performance / Technical Discussions related to performance motor enhancements, upgrades.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 07-12-2018, 06:05 PM   #1  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 2
AFM problems

Ok guys, i have a 78 280z. The engine will randomly die while driving. I'll pull over, struggle to crank it, pull the boot from the afm, spray some starting fluid staight to the tb and she cranks. Recently I figured out I don't even need starter fluid. I just pull off the boot then she starts. She dies soon after. Sometimes ill crank her like this and put the boot on and she immediately dies. Sometimes when I put the boot back on she idles at about 1.8k. Any suggestions?
Juffins is offline   Reply With Quote
Old 07-15-2018, 09:07 PM   #2  
The Good Twin
 
NismoPick's Avatar
 
Join Date: Aug 2005
Location: Wild Wild West, UTAH!
Posts: 20,580
Welcome to ZDriver!
An engine needs 3 things to start (if it's mechanically working properly):
-Proper air delivery
-Proper fuel delivery
-Proper spark delivery

So when it won't start, does it have fuel (fuel pump works? fuel injectors spraying? fuel pressure?)
Does it have spark at all 6 plugs?

When you can start an engine with starter fluid, that means it's not getting proper fuel delivery... either fuel pump isn't working, or injectors aren't spraying.
NismoPick is offline   Reply With Quote
Old 07-16-2018, 07:07 PM   #3  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 2
Ok so I might have it narrowed, but I want to take time to troubleshoot methodically. However, in the early morning and late evening/ night... aka when the sun isn't up and its not hot out, it doesn't do it. It does it whenever everything heats up. I'm thinking vapor lock...
Juffins is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
afm problems seanzzy 280ZX Performance / Technical 0 07-30-2008 07:26 AM
problems problems problems LuVmY280 280ZX Performance / Technical 8 07-18-2007 06:01 AM
AFM BOOT REPAIR ? Brad 240Z, 260Z, 280Z (S30) Forums 6 10-24-2002 01:32 PM
N/A AFM in Turbo AFM Housing datto 240Z, 260Z, 280Z (S30) Forums 4 10-16-2001 10:26 PM
AFM to ECU wire ZenArcher 300ZX (Z31) Forums 1 08-07-2001 03:26 PM


Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 01:38 PM.


Copyright 2000 - 2014 ZDRIVER.COM All Rights Reserved.
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.