240Z, 260Z, 280Z Brakes, Wheels, Suspension and Chassis Discussions related to performance suspension, wheels, brakes and chassis.

260z dies whenever brakes are applied, brake booster maybe?

Old 07-15-2014, 08:12 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jul 2014
Posts: 3
260z dies whenever brakes are applied, brake booster maybe?

My 260 keeps dieing whenever the brakes are applied. Even when idling it lowers the rpms and dies. Does anyome know why? Ive looked it up and said its the brake booster, does anyone know any good upgrades from differnt nissains, or any way to fix it
megaZ is offline  
Old 07-15-2014, 10:11 PM
  #2  
Registered User
 
zxguy1986's Avatar
 
Join Date: Aug 2013
Posts: 1,103
Welcome to ZDriver!

Be sure to pick up a free factory service manual at XenonS30. Lots of other cool docs there too - all of which will be useful in keeping that Z on the road. Check out the inspection and troubleshooting sections in the FSM - which are easy to understand and follow.

Our 260 pros will be right with you. Sounds like an electrical issue to me - but let's see what the pros have to say.

Thanks and welcome!
zxguy1986 is offline  
Old 07-18-2014, 07:21 AM
  #3  
Registered User
 
Join Date: Feb 2011
Posts: 298
Originally Posted by megaZ View Post
My 260 keeps dieing whenever the brakes are applied. Even when idling it lowers the rpms and dies. Does anyome know why? Ive looked it up and said its the brake booster, does anyone know any good upgrades from differnt nissains, or any way to fix it
Where did you read that the brake booster would cause that problem? I'm curious.

Of course, to verify, remove the vacuum line from the intake manifold, and plug it on the manifold. See if it idles properly, etc. Don't drive it like this, though.
Steve260Z74 is offline  
Old 07-18-2014, 07:51 AM
  #4  
Registered User
Thread Starter
 
Join Date: Jul 2014
Posts: 3
Originally Posted by Steve260Z74 View Post
Where did you read that the brake booster would cause that problem? I'm curious.

Of course, to verify, remove the vacuum line from the intake manifold, and plug it on the manifold. See if it idles properly, etc. Don't drive it like this, though.
I read it on one of these forums, it talked about there being a leak and making sure the check valves werent stuck open. But others said it could be a fuel pump or fuel leak. I am at a total lost about the situation but would really like some help, i havent been able to drive it for a while now and just to fix it.
megaZ is offline  
Old 07-18-2014, 10:22 AM
  #5  
Registered User
 
Join Date: Feb 2011
Posts: 298
Okay, so there is a lot of information missing.
Do you have round top or flat top carburetors?
Have you made sure your carburetors and timing have been adjusted per the FSM?
Have you inspected vacuum lines for leaks? (I'm having to replace the line to the check valve myself. The new one arrived yesterday.)
What is the voltage at the battery when the car is idling?
What do your spark plugs look like?
How old is your coil?
Are you still using the stock ignition (Transistor Ignition Unit)?
Is the rotor in good shape?

That should keep you busy for a while. Good diagnostics leads to better solutions (and less money spent on repairs).
Don't forget to look at the troubleshooting guides in the FSM, too.
Steve260Z74 is offline  
Old 04-17-2015, 07:26 PM
  #6  
Registered User
 
Join Date: Apr 2015
Location: B.C. Canada
Posts: 25
There should be a one way check valve leading from a line on the brake booster. This allows regulated vacuum flow to the booster. Also check all vacuum lines. I spray brake clean while the car is running around lines, intakes etc, anything the is exposed to vacuum. If you have a obvious leak, the engine will sputter or change idle quickly. Just watch your eyebrows...
FrappNasty is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
attacksoma
280ZX (S130) Forums
4
03-01-2011 12:34 PM
Dave Hamby
300ZX (Z32) Brakes, Wheels, Suspension and Chassis
5
08-16-2006 05:57 PM
z_nubie
300ZX (Z32) Appearance Exterior, Interior
5
07-17-2006 02:30 PM
s/cL3.0
280ZX Performance / Technical
35
09-10-2005 06:58 PM
Airpilot16
240Z, 260Z, 280Z (S30) Forums
0
04-10-2003 07:29 AM


Thread Tools
Search this Thread
Quick Reply: 260z dies whenever brakes are applied, brake booster maybe?


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.