The Lounge (Off Topic) Talk about daily events, or other items not really related to the ZCars in any way.

I'd like to introduce my RATSUN

Old 06-01-2015, 07:31 PM
  #1  
Registered User
Thread Starter
 
Join Date: May 2015
Location: Katy, Texas
Posts: 3
I'd like to introduce my RATSUN

Hi, I just bought a 1983 Datsun 280zx, and it's relatively clean, seats have been re-upholstered, all the electronics work (aside from the clock) Engine has been rebuilt, only around 500 miles on it, it's cammed (at 260 over whatever stock is) And when she behaves, she runs like a dream, plenty of power, shifts smoothly, clutch is soft, a child could drive this car. However she is straight piped (gonna fix that soon)


-

-

-


But as of recently, she's been bogging down, HARD, massive backfiring (usually around 2k-2500rpm SOMETIMES 1500rpm), loss of power. It only happens when she's warmed up, usually when it's hot out (i live in Texas) I think it might be one of many things.
1. Fuel system
2. cooling problem (problems only happen when warmed up)
3. The straight pipes (back pressure build up)
4. Something is tripping the ecu to trigger fuel cutoff


Now about the cooling issue, on saturday i was driving with some friends to go swimming, and not even halfway to the place we were going to the car started sputtering and backfiring, losing power BADLY, died on the feeder road before i could park her, got her started and running just long enough to park her at nearby park and ride. About 2 or so hours later, a storm hit and it was pouring, it stopped long enough to pick her up and drive her to a friend's place. She ran FINE, and for the rest of that day, she ran FINE. All through the rain, even later in the night when it stopped raining, ran fine

So this is my problem...please help my Ratsun. Thanks in advance.

Last edited by rattattack; 06-02-2015 at 10:31 AM.
rattattack is offline  
Old 06-01-2015, 07:35 PM
  #2  
Registered User
Thread Starter
 
Join Date: May 2015
Location: Katy, Texas
Posts: 3
rattattack is offline  
Old 06-02-2015, 12:20 AM
  #3  
Registered User
 
Skully's Avatar
 
Join Date: Feb 2002
Location: Saskatoon, SK
Posts: 2,886
Sounds like a gem! Pic link is not proper link tho.
Do you have a multimeter? I would try testing CHTS and inspecting the wiring perhaps.
Skully is offline  
Old 06-02-2015, 10:34 AM
  #4  
Registered User
Thread Starter
 
Join Date: May 2015
Location: Katy, Texas
Posts: 3
Originally Posted by Skully View Post
Sounds like a gem! Pic link is not proper link tho.
Do you have a multimeter? I would try testing CHTS and inspecting the wiring perhaps.

Well i checked the CHTS and It looks brand new i took some photos which i will post after work. I just want to get her driveable, so i can actually start driving her
rattattack is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SinCity350Z
Vegas 350Z Club
287
07-09-2012 05:58 PM
Dirty
350Z (Z33) Forums
6
06-05-2012 05:25 AM
Edz280zx
280ZX (S130) Forums
61
06-09-2009 09:25 AM
SwissChEz82
The Lounge (Off Topic)
6
07-12-2005 03:44 PM
ZenArcher
300ZX (Z31) Forums
0
03-13-2001 03:19 AM


Thread Tools
Search this Thread
Quick Reply: I'd like to introduce my RATSUN


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.