300ZX (Z31) Performance / Technical Discussions related to Turbo charging, Supercharging, Engine, ECU, exhaust, and etc. performance enhancements and Techical related.

89 NA2T Car Rough Running Issues

Old 05-01-2017, 07:19 AM
  #1  
Registered User
Thread Starter
 
Join Date: May 2017
Posts: 3
89 NA2T Car Rough Running Issues


I bought my 1989 300zx NA back in 1994 right after highschool graduation. I drove her allthroughout college & she holds a special place in my heart.

About 2 years ago I decided to restore her & do an NA2Tconversion. Now I had done enginerebuilds (two LT1s in a Corvette & Z28). I was not comfortable doing it on the Z so I took the car to Z CarAtlanta & had them rebuild the engine & perform all of the mechanicalwork on the conversion (I purchased all of the necessary parts including a newT3/T4 rebuild from Arizona Turbo). They dida great job mechanically. Drove it homeback in 2015. I wanted to send out theECU to JWT for a program. When I pulledit turns out they swapped in an ECU from a 1985 NA. I called them up & they said my originalwould not run with the old ecu so they swapped it. I asked for mine back & they said theysent it in as the core. (Not here to discuss that issue BTW the guys did agreat job mechanically on the car and fixed some issues I did not ask them too)
Iíve done all the painting & interior/exteriorrestorations for the past 2 years. So Iam just now getting to the mechanical issues.
At any rate, I bought a used 88-89 NA ecu from ebay, sent itto JWT with all of my specs & got it back. Car has several issues
  • Its verydifficult to get it to start & idle when cold. Takes usually 5 minutes to get it started& if you press the accelerator too soon the car will die.
  • Once the car has warmed up it does not runsmoothly below 3000 RPM. After I let itwarm up & drive it I go WOT & the car does boost to between 5 & 7PSI (new wastegate that is set at 7 PSI) car seems to accelerate well at WOTabove 3000.
  • After warmed up the car wants to idle at1200-1300 RPMs. It will intermittently dieafter it warms up.
I checked the ECU codes yesterday. Let them cycle through twice & recordedthe following faults
Code 13-CHTS Cylinder Head Temperature Sensor
Code 22-Fuel Pump Circuit (Odd to me since the pump is new& runs fine)
Code 23-Idle Switch Circuit
Code 33-Exhaust Gas Sensor
Code 42- Fuel Temperature Sensor

Engine, fuel pump and everything is new on the vehicle(engine has about 100 miles on it).

Any thoughts? The multiple codes is whathas me scratching my head. Could the ECUbe bad? Are JWT ECUs known for thesemalfunctions? Should I just startreplacing the sensors associated with the faults.


Metlbeast is offline  
Old 05-08-2017, 04:21 AM
  #2  
Registered User
Thread Starter
 
Join Date: May 2017
Posts: 3
*UPDATE*


I swapped in a stock 89 Turbo ECU this weekend to eliminate the ECU as the problem.




Took out the JWT ECU put the Stock 89 Turbo one in. Hooked up the battery, turned the ignition. Car immediately cranked & ran relatively smoothly. Let it warm up then drove it around a bit. No missing or hesitation through the RPM range. Idle is still too high but I will try adjusting that.


It is possible that the ECU was bad when it was sent to JWT for the tune but I am not so sure. Not happy with JWT right now.
Metlbeast is offline  
Old 05-11-2017, 10:00 AM
  #3  
The Good Twin
 
NismoPick's Avatar
 
Join Date: Aug 2005
Location: Wild Wild West, UTAH!
Posts: 20,616
Welcome to ZDriver!

Have you contacted JWT about it yet?
NismoPick is offline  
Old 05-11-2017, 11:01 AM
  #4  
Registered User
Thread Starter
 
Join Date: May 2017
Posts: 3
Originally Posted by NismoPick View Post
Welcome to ZDriver!

Have you contacted JWT about it yet?






I haven't had a chance to yet. Its been over a year since I purchased the tune. I had planned on installing the JWT 420cc/min injectors a Z32 TT Fuel pump, installing a FMIC & sending them the ECU back for an upgrade. I hope to call them this week & see what they have to say.
Metlbeast is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Z31Gold
Wanted (WTB / WTT)
5
06-12-2014 10:39 AM
1988Z31
300ZX (Z31) Forums
1
03-14-2014 05:29 PM
soysauce300zx
300ZX (Z31) Forums
8
07-18-2012 05:53 PM
skygunner58203
Wanted (WTB / WTT)
5
11-27-2011 03:24 PM
omniserv
300ZX (Z31) Performance / Technical
2
06-05-2011 01:26 PM


Thread Tools
Search this Thread
Quick Reply: 89 NA2T Car Rough Running Issues


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.