300ZX (Z31) Performance / Technical Discussions related to Turbo charging, Supercharging, Engine, ECU, exhaust, and etc. performance enhancements and Techical related.

86 300 NA, Is my fuel pump going bad ?

Old 12-22-2017, 10:21 AM
  #1  
Registered User
Thread Starter
 
Join Date: Jul 2017
Posts: 4
86 300 NA, Is my fuel pump going bad ?

Went to start my 300 last night and didn't hear the normal priming hum of the fuel pump, the car wouldn't start after five or six tries, so I unplugged and re-plugged the fuel pump under the back carpet and also took off the negative battery terminal in reconnected it, then I turn the key and I get the normal hum and it started right up? Does that mean feel pump is going bad or is it something else?
Mojobaby27 is offline  
Old 12-26-2017, 10:36 AM
  #2  
Registered User
 
Cobalt60's Avatar
 
Join Date: Dec 2017
Posts: 33
Sounds more like a bad connection than a pump performance issue.

You could check the discharge pressure of the pump by installing a gage.
Cobalt60 is offline  
Old 12-27-2017, 10:11 AM
  #3  
Registered User
Thread Starter
 
Join Date: Jul 2017
Posts: 4
I'll check the electrical, thanks for the idea

I'll check the electrical power and relays, as well as the fuel pressure, I'm pretty sure I can get the gauges at the auto store, loan program or rental? Thanks
will update.
Mojobaby27 is offline  
Old 05-13-2019, 11:54 AM
  #4  
Registered User
 
Raylene's Avatar
 
Join Date: May 2019
Location: TN
Posts: 5
Similar

Had a similar issue n pulled the panel trim behind pass seat and tested fuel pump relay. Put power on it n figured out that was the issue n not the 1000 other things it could be lol
Raylene is offline  
Old 05-13-2019, 03:30 PM
  #5  
Registered User
 
Join Date: May 2019
Posts: 3
fuel pump relay?

Originally Posted by Raylene View Post
Had a similar issue n pulled the panel trim behind pass seat and tested fuel pump relay. Put power on it n figured out that was the issue n not the 1000 other things it could be lol


Okay; can you describe to me exactly where you found the fuel pump relay? Iíve been looking forever and canít find it anywhere. Not under the hood, not by the fuse bix, Iíve heard behind passenger seat like you but not sure where back there. Just give me an in depth description
Tristan King is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
WylieCoyote88
Site Brainstorming
1
08-06-2017 10:57 AM
sameerb1
280ZX (S130) Forums
6
03-20-2011 05:21 AM
Mike Phillips
240Z, 260Z, 280Z Performance / Technical
3
10-20-2006 02:28 PM
280ZXtreme
240Z, 260Z, 280Z (S30) Forums
1
04-10-2001 07:00 AM


Thread Tools
Search this Thread
Quick Reply: 86 300 NA, Is my fuel pump going bad ?


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.