Go Back  ZDriver.com > Cars > 300ZX (Z31) Forums
Sensor light and gas light came on. Fuel issues >

Sensor light and gas light came on. Fuel issues

300ZX (Z31) Forums Dedicated to 84-89 ZCars otherwize known as the Z31's

Sensor light and gas light came on. Fuel issues

Old 05-11-2019, 05:44 PM
  #1  
Registered User
Thread Starter
 
Join Date: May 2019
Posts: 3
Sensor light and gas light came on. Fuel issues

Both sensor and Gas light are on in my 87 300zx non turbo. Bought it like that. I put gas in and itís still showing empty. Engine will crank but no start. I turn the key and I canít hear the relay clicking. Is there an intertia switch? Iím curious if both the sending unit and pump are bad.
Tristan King is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
joel280zt
280ZX (S130) Forums
10
08-02-2012 06:10 AM
rgus30
280ZX Performance / Technical
8
09-04-2006 10:27 AM
rustynogood
300ZX (Z32) Brakes, Wheels, Suspension and Chassis
17
01-04-2006 07:33 PM
81 Black L28E
280ZX (S130) Forums
1
08-14-2005 12:27 PM
Dryz
240Z, 260Z, 280Z (S30) Forums
2
05-30-2002 12:28 AM


Thread Tools
Search this Thread
Quick Reply: Sensor light and gas light came on. Fuel issues


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.