300ZX (Z31) Forums Dedicated to 84-89 ZCars otherwize known as the Z31's

Bad MAF

Old 05-07-2011, 02:51 PM
  #1  
Registered User
Thread Starter
 
86_VG30ET_Z31's Avatar
 
Join Date: Aug 2010
Location: Santa Maria, Ca
Posts: 62
Bad MAF

I have a 86 300zx turbo with wat i think is a bad MAF sensor. A few days ago the car was running great but i had a leak on my intercooler set up. an one day i had to drive it on a rainy day an when i passed throu Huge puddle of water the intercooler sucked in water from a lose cuopler an it started to stall an hesitate. next day i checked an there was alot of water inside the MAF sensor an since then ita been runnin like crap it struggles to pass 4500rpms an boggs down i wanted to knoe how can i troubleshoot the maf to find if its bad cause from the wat i seen prices they are around $200 to $300 new with one year warranty but i want to make sure dat its bad before i can replace it
86_VG30ET_Z31 is offline  
Old 05-07-2011, 09:31 PM
  #2  
Registered User
 
Join Date: Apr 2011
Posts: 51
my car had a bad maf you can pull the air box intake off the maf while the car is running and itll sound like the car is coming to life. and it idles really rough if its bad. Car was hesistant to get up and go from a start. oh you can try unplugging the maf and start up the car to see how it idles its gonna stall out though but thatll tell you if its bad
illldeca is offline  
Old 05-07-2011, 10:30 PM
  #3  
Registered User
 
borini63's Avatar
 
Join Date: Aug 2009
Location: Phoenix AZ + (Q8)
Posts: 1,223
I have one just sitting on the shelf.
You can have it for $45 shipped.
Let me know if your maf is shot.I will send you the one I have!
Jamal

borini63 is offline  
Old 05-07-2011, 10:31 PM
  #4  
Registered User
Thread Starter
 
86_VG30ET_Z31's Avatar
 
Join Date: Aug 2010
Location: Santa Maria, Ca
Posts: 62
U tried it an it idles better but is there any other way to check if its bad
86_VG30ET_Z31 is offline  
Old 05-08-2011, 06:45 AM
  #5  
Registered User
 
Join Date: Apr 2011
Posts: 51
Originally Posted by 86_VG30ET_Z31 View Post
U tried it an it idles better but is there any other way to check if its bad
ya you can drive for a while take off the intake and look into the maf in the if the little wires inside are red hot its supose to be good i think. I would assume its easy just to unplug it and see how it runs for a brief period. I will stall but no dig deal
illldeca is offline  
Old 05-08-2011, 08:41 AM
  #6  
Grumpy & Helpful
 
Join Date: Sep 2006
Location: Mill Creek WA
Posts: 1,415
download the fsm from xenon. there is a test procedure there using a vom. first thing I'd do is pull the connector apart and check for water and the tps also. try the junkyards any z31 maf will work. most likely tho if you dry everything out you will be fine.
rogerz is offline  
Old 05-08-2011, 02:06 PM
  #7  
Registered User
Thread Starter
 
86_VG30ET_Z31's Avatar
 
Join Date: Aug 2010
Location: Santa Maria, Ca
Posts: 62
Thanks for all the help the wires wont get red hot an i troubleshoot it as the fsm said an its bad
86_VG30ET_Z31 is offline  

Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.