'84 slicktop update and a question - ZDriver.com

Go Back  ZDriver.com > Cars > 300ZX (Z31) Forums
'84 slicktop update and a question >

'84 slicktop update and a question

300ZX (Z31) Forums Dedicated to 84-89 ZCars otherwize known as the Z31's

'84 slicktop update and a question

Old 07-06-2018, 02:00 PM
  #1  
Registered User
Thread Starter
 
Join Date: Sep 2017
Location: Northwest AR
Posts: 8
'84 slicktop update and a question

It's been slower than I would like, but progress is being made on the little white car. Changed the interior color from tan/ beige to mostly parchment (SEM vinyl stuff) and rebuilt the seats with a z32 pattern cloth. So far, she runs good, but will not run out. Max speed on the highway is around 70 mph. Seems to rev smoothly but slowly. So far, I have replaced plugs dist. cap and wires, changed to PRW module, replaced timing belt and associated hardware, changed fuel filter and checked pressure, cleaned MAF sensor, new clutch master and slave (bypassed damper) fresh panel air filter. Tried a tank full of some expensive injector cleaner and checked brake calipers for binding (one seemed a little tight from the parking brake spring bracket not moving, but some oil and movement fixed that). Timing is set at 20 degrees.

The question is for anyone who can think of something I have overlooked. Any ideas?

Thanks. [email protected]
Doclee is offline  
Old 11-21-2018, 03:42 PM
  #2  
Registered User
Thread Starter
 
Join Date: Sep 2017
Location: Northwest AR
Posts: 8
Follow up

Originally Posted by Doclee View Post
It's been slower than I would like, but progress is being made on the little white car. Changed the interior color from tan/ beige to mostly parchment (SEM vinyl stuff) and rebuilt the seats with a z32 pattern cloth. So far, she runs good, but will not run out. Max speed on the highway is around 70 mph. Seems to rev smoothly but slowly. So far, I have replaced plugs dist. cap and wires, changed to PRW module, replaced timing belt and associated hardware, changed fuel filter and checked pressure, cleaned MAF sensor, new clutch master and slave (bypassed damper) fresh panel air filter. Tried a tank full of some expensive injector cleaner and checked brake calipers for binding (one seemed a little tight from the parking brake spring bracket not moving, but some oil and movement fixed that). Timing is set at 20 degrees.

The question is for anyone who can think of something I have overlooked. Any ideas?

Thanks. [email protected]
Weak engine was sourced to a pair of wired that had been chewed up and overlooked by yours truly, resulting in passenger side bank of cylinders not getting any fuel. Corrected and now the little car runs like a champ.
Doclee is offline  
Old 11-22-2018, 01:42 AM
  #3  
Registered User
 
Join Date: Aug 2014
Posts: 23
Excellent. Check advance on distr, both mechanical and vacuum, Good bet more power will be found in either not functioning proper. Need the advance when we push the happy pedal, Then a set of new injectors and connectors. Badda bam
!
mikey280zx is offline  
Old 11-24-2018, 09:23 AM
  #4  
Registered User
 
Join Date: Nov 2013
Location: east KS
Posts: 291
When you load the engine, ignition timing retards
​​​​​​​like at idle load
86tcoupe is offline  
Old 11-25-2018, 11:27 PM
  #5  
Registered User
 
Join Date: Aug 2014
Posts: 23
If it's retarding performance must be bad. No advance when rev w timing light?
mikey280zx is offline  
Old 11-27-2018, 08:11 AM
  #6  
Registered User
 
Join Date: Nov 2013
Location: east KS
Posts: 291
Originally Posted by mikey280zx View Post
if it's retarding performance must be bad. No advance when rev w timing light?
It is already advanced it needs to retard as the throttle opens for a sustained time under load.
​​​
​​​​​​​how would reving be a load?

Last edited by 86tcoupe; 11-27-2018 at 08:22 AM.
86tcoupe is offline  
Old 12-20-2018, 03:11 PM
  #7  
Registered User
Thread Starter
 
Join Date: Sep 2017
Location: Northwest AR
Posts: 8
Okay, all the mechanical and almost all the interior stuff has been taken care of. Still need to swap out the faded odometer barrels, or possible the entire instrument panel with a spare, find out why the HVAC system isn't working (I got nothin' so plan is to pull the dash apart and look for some bad vacuum hoses).

Next is paint and body along with a new windshield. Then, of course, all will be well and i should never have to fix anything again...right?
Doclee is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
professor229
240Z, 260Z, 280Z Performance / Technical
8
01-31-2013 04:21 AM
corbith
280ZX (S130) Forums
7
11-05-2012 05:35 AM
AbsolutZ
For Sale (VIEW ALL)
0
12-16-2003 03:26 PM
karma
For Sale (VIEW ALL)
14
08-08-2003 03:16 PM
00Evan
For Sale (VIEW ALL)
0
05-06-2003 08:55 AM


Thread Tools
Search this Thread
Quick Reply: '84 slicktop update and a question


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.