84 300zxt electrical fun - ZDriver.com

Go Back  ZDriver.com > Cars > 300ZX (Z31) Forums
84 300zxt electrical fun >

84 300zxt electrical fun

300ZX (Z31) Forums Dedicated to 84-89 ZCars otherwize known as the Z31's

84 300zxt electrical fun

Old 09-26-2018, 07:00 PM
  #1  
Registered User
Thread Starter
 
Join Date: Sep 2018
Location: Lewiston,Id
Posts: 14
84 300zxt electrical fun

Recently the digital dash in my 84 300ZXT quit working.turn signals,warning lights,etc all still work but no joy from the digi dash of 80's awesome-ness.Before it would sometimes not work and hitting the dash would make it come back on so I was thinking it was the power unit being faulty.So I took it out and resoldered all the pins but still no joy.So I checked the fuses and all of them work as indicated by my multimeter. So before I go track down a good power unit or convert to an analog dash is there anything alse I could check out?

Also the electronic climate control has never worked for as long as I have owned the car.While I was poking the fuse panel with my multimeter I discovered that there is NO POWER to the Aircon Blower fuses.So I checked the relay and checked for power/continuity at the terminals and everything checks out.If I run a jumper wire from one of the many wires supplying power to the fuse panel and run it to the aircon blower fuses, I can turn the climate control on and it works, hardware failures not withstanding (the heater core leaks and was bypassed by the previous owner,and I deleted the AC). So there is a break in the wire that feeds the aircon blower circuit somewhere between the relay and the fuse panel,any areas I should check in particular before I say "screw it" and run a jumper lead from a wire supplying the fuse panel to the air con?it would be awesome to have a functional defrost even if I don't have any heat just to keep the windshield fog free.I can bundle up its just hard to see where your going when the window fogs up at less than 20 mph.
RallyZX is offline  
Old 09-27-2018, 04:43 PM
  #2  
Registered User
 
Join Date: Nov 2013
Location: east KS
Posts: 295
There was a problem and it sounds like it might be a bad connection at the multiplug to the printed circuit . I remember back then many were failing and the printed circuit was $900
86tcoupe is offline  
Old 09-27-2018, 06:41 PM
  #3  
Registered User
Thread Starter
 
Join Date: Sep 2018
Location: Lewiston,Id
Posts: 14
It better not be $900.I'll build a custom instrument cluster long before I will pay $900 for an electrical gizmo to run the dash on a $800 car.
RallyZX is offline  
Old 09-28-2018, 04:49 PM
  #4  
Registered User
 
Join Date: Nov 2013
Location: east KS
Posts: 295
Yeah ...I hear you The complete assy was $2700 and some were stolen , you have to know it is produced by nabco or mitsu etc. They charge thier profit for nissan, then sold to nissan north america +100% markup + 100% dealer markup

Last edited by 86tcoupe; 10-01-2018 at 06:35 AM.
86tcoupe is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
duckyz
280ZX (S130) Forums
9
07-04-2012 11:38 PM
HeRo ShiRo
For Sale (VIEW ALL)
1
08-13-2003 08:35 PM
ZippiZ
300ZX (Z31) Forums
4
09-22-2002 12:24 AM
joethegoffer
300ZX (Z31) Forums
1
03-06-2002 03:49 AM
Zpeed
300ZX (Z31) Forums
1
02-08-2002 04:51 PM


Thread Tools
Search this Thread
Quick Reply: 84 300zxt electrical fun


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.