300ZX (Z31) Forums Dedicated to 84-89 ZCars otherwize known as the Z31's

1987 N/A turbo conversion HELP

Old 02-16-2016, 02:28 PM
  #1  
Registered User
Thread Starter
 
Join Date: Feb 2016
Posts: 4
Cool 1987 N/A turbo conversion HELP

Hey guys I could really use some help with my Z31! I have a 1987 two seater I traded for a Honda when I was 18 it was N/A and it ran like a top for about three years. Somehow I managed to snap the pulley on my crankshaft, so my brother convinced me to do the turbo swap. I bought a running 1985 Z31 Turbo. I swapped the motor with the wiring harness still all connected, and brought the turbo ECU, and crossmember over to me car with it. I did keep my original transmission because or else I would have had to swap the entire driveline I believe. When I turn the key the starter cranks but my ignition coil does not get any power and neither does the fuel pump. I have wired the fuel pump directly up to power to ensure that it is working, it is. I did have some confusion when I was wiring up the alternator for some reason it seems like I have two sets of wires going to the alternator.. hmm.. I cant figure that one out. There was a hot wire that touched metal and made a huge spark the first night we tried starting it, it fried one of the fusible links located next to the battery I swapped all them out with the ones from my “parts car, 85 turbo Z” I tried to look for shorts in the system by having a tester light connected to the positive batter terminal ( disconnected from the batter) and the other end on the positive terminal, no luck. I have checked all the grounds that I could find they all seem to be connected well. One other weird thing my turbo ECU seems to be stuck in a certain mode, when I turn the mode selector clockwise with the ignition on the red and green lights do not blink together its as if their already shooting out codes, I tried to do the steps to reset it but it still does the same thing. I connected my N/A ECU just for ***** the fuel pump nor the ignition coil still do not get power however that ecu seems to be functioning as far as the red and green lights blinking together to let me choose the mode and when I do go into mode 3 with the N/A ECU it gives me code 44 which I guess meens “no codes” “ normal operation, lol. This post is my last hope for this setup if I cannot figure this out then I am going to buy a stand alone ECU and go that route, however I would really prefer to use my tax return for suspension, but at this point I just want my fairlady to run, even if she does ride like a boat on land,lol. Any ideas would be much appreciated thanks for reading my post.
fairlady_lea is offline  
Old 02-21-2016, 01:52 PM
  #2  
Registered User
Thread Starter
 
Join Date: Feb 2016
Posts: 4
bump

bump
fairlady_lea is offline  
Old 02-22-2016, 09:14 AM
  #3  
The Good Twin
 
NismoPick's Avatar
 
Join Date: Aug 2005
Location: Wild Wild West, UTAH!
Posts: 20,616
Unfortunately when you burn a fusible link, the ecu can sometimes still get fried. Without actually looking at your wiring, or pics, it's pretty hard to diagnose. I'd start with checking if the ecu is outputting spark signal on pin 5, and if it's sending ground signal to the fuel pump relay. I'm hoping you already have the FSM...
NismoPick is offline  
Old 02-22-2016, 09:27 AM
  #4  
Registered User
Thread Starter
 
Join Date: Feb 2016
Posts: 4
Thanks!

Originally Posted by NismoPick View Post
Unfortunately when you burn a fusible link, the ecu can sometimes still get fried. Without actually looking at your wiring, or pics, it's pretty hard to diagnose. I'd start with checking if the ecu is outputting spark signal on pin 5, and if it's sending ground signal to the fuel pump relay. I'm hoping you already have the FSM...
I have access to the FSM I found a website where I can view it I have a Chilton but it's crappy!!! I will check pin five and the fuel pump relay I did try swaping out relays from my parts car, and just for ***** I connected my N/A ECU because I heard it will still start and run with that ECU. Thanks for the advice I'll let you know what I find out!

Last edited by fairlady_lea; 02-22-2016 at 09:28 AM. Reason: Meant to say 5 not 3
fairlady_lea is offline  
Old 03-19-2017, 03:14 PM
  #5  
Registered User
 
Join Date: Mar 2017
Posts: 1
Smile

Couldn't find where to start a new thread to save my life.

I just bought a new z31 tranny and would like to know how to tell if it's a fs5r30a or a fs5r90a.
Hector_300zx is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
OsidonZ31
Wanted (WTB / WTT)
3
09-07-2013 06:48 PM
teamadidas
For Sale (VIEW ALL)
0
06-02-2005 04:41 PM
teamadidas
FS: 300ZX (84-89)
1
10-03-2004 03:07 PM
jeff_t
For Sale (VIEW ALL)
1
04-21-2004 01:58 PM
CraizieCracka
Wanted (WTB / WTT)
2
01-20-2004 06:49 PM


Thread Tools
Search this Thread
Quick Reply: 1987 N/A turbo conversion HELP


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.