1979 280zx Deceleration Problems - ZDriver.com

Go Back  ZDriver.com > Cars > 280ZX (S130) Forums
1979 280zx Deceleration Problems >

1979 280zx Deceleration Problems

280ZX (S130) Forums Dedicated to 79-83 ZCars

1979 280zx Deceleration Problems

Reply

 
 
 
Old 03-22-2016, 12:36 PM
  #1  
Registered User
Thread Starter
 
Join Date: Mar 2016
Posts: 2
1979 280zx Deceleration Problems

Hi guys! First post here.
I got my 1979 280zx a while ago, and have been giving it the maintenance it deserves. I fixed a lot of stuff that was wrong with her already, and the only thing that I have left to figure out how to fix is this:

When I decelerate quickly, the motor has a hard time holding the idle. Let's say you have it in neutral and want to rev it to impress your friends. The revs go way below 1000 when you let off the gas, and sometimes the motor stops. It has a hard time going back to idle. Reading for a while, and inspecting around the engine bay, I found a vacuum port without anything attached to it, just below the throttle body. I think this has to go to the canister (the canister was missing the vacuum line as well) and it's the boost controlled deceleration device vacuum port. The canister also has another port, that goes to the distributor, but I didn't find any vacuum ports on my distributor to connect it there. So, do you guys think is there a way to make it work without these vacuum lines? Should I get a new distributor with this vacuum port on it? I already connected the throttle body port where it should be, according to the canister (it has a sticker that says so), but I have another port without anything attached to it, and the canister says it has to go to the distributor. Thoughts? Any help is appreciated a lot!
tavomeister is offline  
Reply With Quote
Old 03-22-2016, 09:17 PM
  #2  
Registered User
 
kraztrini's Avatar
 
Join Date: Mar 2006
Posts: 22
Thumbs up Boost Controlled Deceleration Device

I also own a '79. I will check on the vacuum hose flow and get back to you
kraztrini is offline  
Reply With Quote
Old 03-23-2016, 07:28 AM
  #3  
Registered User
Thread Starter
 
Join Date: Mar 2016
Posts: 2
Thank you very much!
tavomeister is offline  
Reply With Quote
Old 03-24-2016, 12:14 PM
  #4  
The Good Twin
 
NismoPick's Avatar
 
Join Date: Aug 2005
Location: Wild Wild West, UTAH!
Posts: 20,613
Welcome to ZDriver!

The FSM has many helpful vacuum diagrams: XenonZcar.com S130 Factory Service manuals
NismoPick is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jalexquijano
240Z, 260Z, 280Z Performance / Technical
7
10-21-2014 09:41 AM
craftm
300ZX (Z32) Performance / Technical
35
04-17-2008 01:57 PM
LuVmY280
280ZX Performance / Technical
8
07-18-2007 07:01 AM
goldenstoomuch
240Z, 260Z, 280Z (S30) Forums
1
07-01-2003 06:46 PM
vltjr
240Z, 260Z, 280Z (S30) Forums
3
04-03-2002 11:20 PM


Thread Tools
Search this Thread
Quick Reply: 1979 280zx Deceleration Problems


Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.