240Z, 260Z, 280Z Performance / Technical Discussions related to performance motor enhancements, upgrades.

my 280z shuts off while driving

Old 04-28-2008, 01:44 AM
  #1  
Registered User
Thread Starter
 
Join Date: Apr 2008
Posts: 1
my 280z shuts off while driving

I have an automatic 76 280z, it starts and runs.

the engine runs strong but feels like the fuel will stop going to the engine sometimes, and i cant really go over 45 mph.

if i try to drive it normally it will shut off

dosent shut off on idle... except after 2 minnutes it'll act like gas is not going into the engine choke a bit and then turn off...

but then i can start it up again...

if i leave the key on before starting, it makes a noise in the back under the car... from the fuel area i think... a buzzing kind of noise is that normal?

the best way to describe the way it acts... is that it shuts off randomly while driving.. please help me out thanx.
dainamikus is offline  
Old 04-28-2008, 05:42 AM
  #2  
Über User
 
snwbrderphat540's Avatar
 
Join Date: Sep 2005
Location: lemont, Illinois
Posts: 9,532
daina mikus? are you a Lithuanian girl? lol. idk just curious

also, that buzzing is the fuel pump. you sound like you got a fairly serious problem. you could start by trying to check the fuel pressure. sounds like you need a crash course in cars and car maintenance though
snwbrderphat540 is offline  
Old 04-28-2008, 06:16 AM
  #3  
The Good Twin
 
NismoPick's Avatar
 
Join Date: Aug 2005
Location: Wild Wild West, UTAH!
Posts: 20,616
Welcome to ZDriver dainamikus!

If you haven't done so yet, buy a 240z-280z Haynes Repair / Service manual... lots of good info in there. Like Snw said, start diagnosing the prob by checking what you can... fuel pressure, sensors (and sensor connections), wiring, timing, spark plug tips (this will give you an idea of how the engine is running).
NismoPick is offline  
Old 04-28-2008, 09:38 AM
  #4  
I have a present for you...
 
theramz's Avatar
 
Join Date: Mar 2003
Location: dayton, nevada usa
Posts: 1,661
Originally Posted by dainamikus
I have an automatic 76 280z, it starts and runs.

the engine runs strong but feels like the fuel will stop going to the engine sometimes, and i cant really go over 45 mph.

if i try to drive it normally it will shut off

dosent shut off on idle... except after 2 minnutes it'll act like gas is not going into the engine choke a bit and then turn off...

but then i can start it up again...

if i leave the key on before starting, it makes a noise in the back under the car... from the fuel area i think... a buzzing kind of noise is that normal?

the best way to describe the way it acts... is that it shuts off randomly while driving.. please help me out thanx.
Yeah, get the manuals by all means and learn about your car. Before you rush out and buy a bunch of test equipment turn the key on and listen to the pump. If it makes a steady buzz it's probably ok. Actually it isn't suppose to run until you hit start, not that important. It might be as simple as the fuel filter needs to be changed. Add some injector cleaner to the tank and see if that helps. Welcome to Zdriver, you've just begun grasshopper!
theramz is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Pilgrim
280ZX (S130) Forums
11
09-30-2018 05:16 PM
Domi's 75 280z
240Z, 260Z, 280Z (S30) Forums
6
05-31-2015 12:25 AM
Brian Crandall
300ZX (Z31) Forums
7
01-09-2013 06:47 AM
3XAZOWNER
280ZX (S130) Forums
10
07-17-2006 06:06 AM
ensmuns
Vegas 350Z Club
5
06-19-2006 04:01 AM


Thread Tools
Search this Thread
Quick Reply: my 280z shuts off while driving


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.