Headlight not working (Driver Side) - ZDriver.com

Go Back  ZDriver.com > Miscellaneous > The Dark Room - Photo / Video / Music
Headlight not working (Driver Side) >

Headlight not working (Driver Side)

The Dark Room - Photo / Video / Music Photo / Video / Film / Music / Media Discussions

Headlight not working (Driver Side)

Old 05-28-2016, 11:21 PM
  #1  
Registered User
Thread Starter
 
Join Date: May 2016
Posts: 6
Headlight not working (Driver Side)

Hi All,

I have a headlight issue. Driver side headlight is not working. Fog lamps on both sides work, and passenger headlight works.......just not drivers light.

Checked fuse, was good, but replaced it anyway. Still no headlight.
Removed working headlight on passenger side and moved it to drivers side and no light.

So, my question is. Is there a relay for the drivers side headlight somewhere that I'm not checking,or aware of? Where is the location of said relay?

Thanks,
wtdfxup is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
turbotim
300ZX (Z31) Performance / Technical
2
05-04-2013 04:28 PM
TeknikL
FS: 300ZX (90-96)
0
12-07-2012 03:10 PM
GARYZ240
Wanted (WTB / WTT)
0
02-28-2008 01:43 AM
280zdrag'r
240Z, 260Z, 280Z (S30) Forums
1
10-03-2005 02:12 PM
Splice
300ZX (Z31) Forums
1
09-11-2002 10:19 AM


Thread Tools
Search this Thread
Quick Reply: Headlight not working (Driver Side)


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.