03 nissan 350z stalls after startup - ZDriver.com

Go Back  ZDriver.com > Cars > 350Z (Z33) Forums > 350Z Performance / Technical
03 nissan 350z stalls after startup >

03 nissan 350z stalls after startup

350Z Performance / Technical Discussions related to Turbo charging, Supercharging, Engine, ECU, exhaust, and etc. performance enhancements and Techical related.

03 nissan 350z stalls after startup

Reply

 
 
 
Old 01-21-2013, 11:17 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jan 2013
Posts: 1
03 nissan 350z stalls after startup

I have an 03 Nissan 350z with 102k miles on it. I checked the codes and I have a knock sensor code that popped up so I know I have to replace that but im not sure if thats whats causing the car to stall after starting it up when the engine is hot. However, when the car is cold it starts normally and idles normally however, after driving it and the car gets hot, once I turn off the car and start it back up while it is hot, the car revs up and continues to die down and stalls. When I press on the gas a little bit in this situation it goes to a normal idle and drives perfectly. has anybody got this type of problem and knows how to solve it? much help is appreciated.
elvee18 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RexRunner531
FS: 350Z / 370Z (03+)
0
10-16-2013 09:40 PM
fenvy
FS: 350Z / 370Z (03+)
0
06-02-2013 12:36 AM
Mishimoto
350Z (Z33) Forums
1
04-15-2013 08:15 AM
VIP Modular Wheels
350Z Brakes, Wheels, Suspension and Chassis
0
09-20-2011 12:01 PM
enxss
Wanted (WTB / WTT)
0
05-18-2009 06:20 AM


Thread Tools
Search this Thread