Old style injector trouble- Please need some advise! - ZDriver.com

Go Back  ZDriver.com > Cars > 300ZX (Z32) Forums
Old style injector trouble- Please need some advise! >

Old style injector trouble- Please need some advise!

300ZX (Z32) Forums Dedicated to 90-96 ZCars otherwize known as the Z32's

Old style injector trouble- Please need some advise!

Reply

 
 
 
Old 06-01-2018, 10:23 AM
  #1  
Registered User
Thread Starter
 
Join Date: Dec 2017
Posts: 1
Old style injector trouble- Please need some advise!

I have a 1991 NA with old style injectors. I do have a paper copy of the factory service manual. I had a rough idle condition and when testing it revealed cylinder #4 showing no injection. Coil was within resistance specs, spark plug new, and the injector has no "click" when turning the CAS. I hear clicks on all other cylinders. Using a logic probe, I checked the #4 connector and, when disconnected from the injector, I have one pole with constant power and the other no power except when I rotate the CAS and hear clicks on the remaining injectors. I do get a momentary light on that one pole when turning the CAS. I believe this tells me the signal from the computer is good? When I compare this behavior to cylinder #2 injector connector the behavior of cylinder #4 connector is the same. Once I plug in an injector (or 2 other test injectors that all show ohms within spec) and when back probing the connector I get both poles showing power and while rotating the CAS I get no click.

I am pretty confident someone on this forum can help me figure out why this is occurring !

Thanks in advance! I am new to this group and very much look forward to good things from this car. Once I get the car running better, I plan on replacing all the old style injectors with a brand new system but removal of the plenum is daunting at this point.

Grant
Gooldg is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dennys93na300z
300ZX (Z32) Forums
3
10-15-2014 10:05 PM
Lovenpain
For Sale (VIEW ALL)
0
02-26-2012 12:35 AM
silverz32
300ZX (Z32) Forums
0
02-25-2012 08:23 AM
KasbeKZ
FS: 300ZX (90-96)
0
04-04-2010 06:36 PM


Thread Tools
Search this Thread