300ZX (Z31) Forums Dedicated to 84-89 ZCars otherwize known as the Z31's

z31 strange headlight issue

Old 04-27-2015, 03:40 PM
  #1  
Registered User
Thread Starter
 
Join Date: Oct 2014
Posts: 8
Exclamation z31 strange headlight issue

hey there guys, after jump starting my 84 300zx turbo 5spd 137k the headlights will not good off. I replaced the headlight switch on the steering wheel and it still did the same thing. They go off when I open the passengers side door. Ive also noticed that if take the fuses out and put them back in, the headlights will not come on until I turn the switch. I know this is a shot in the dark but I hope someone can help. Thank you! P.S sometimes I hear a relay clicking really fast under hood!
Attached Thumbnails z31 strange headlight issue-z6.jpg  
Juanz31 is offline  
Old 04-29-2015, 03:11 PM
  #2  
Registered User
 
Join Date: May 2014
Location: Texas
Posts: 137
My only suggestion is to check/replace the Uphold relay for the headlights. Its on the passenger side of the car by the battery. The relay is BLACK in color
Zuphoria is offline  
Old 04-29-2015, 09:00 PM
  #3  
Registered User
Thread Starter
 
Join Date: Oct 2014
Posts: 8
Originally Posted by Zuphoria View Post
My only suggestion is to check/replace the Uphold relay for the headlights. Its on the passenger side of the car by the battery. The relay is BLACK in color
Thank you! It's not with the other relays in the black box ?
Juanz31 is offline  
Old 04-29-2015, 09:01 PM
  #4  
Registered User
Thread Starter
 
Join Date: Oct 2014
Posts: 8
Originally Posted by Zuphoria View Post
My only suggestion is to check/replace the Uphold relay for the headlights. Its on the passenger side of the car by the battery. The relay is BLACK in color
okay now I know what you are talking about, thank you!
Juanz31 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Defender405
300ZX (Z31) Forums
11
05-28-2015 08:48 PM
wrich47
300ZX (Z32) Forums
15
10-10-2013 07:08 PM
gilgunderson
300ZX (Z32) Performance / Technical
2
03-14-2013 09:39 PM
mpv06c
300ZX (Z31) Performance / Technical
0
02-08-2013 02:12 PM
litohmongboy
280ZX (S130) Forums
3
03-23-2009 04:22 PM


Thread Tools
Search this Thread
Quick Reply: z31 strange headlight issue


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.