When it rains...seems water gets into electronics or something - ZDriver.com

Go Back  ZDriver.com > Cars > 300ZX (Z31) Forums
When it rains...seems water gets into electronics or something >

When it rains...seems water gets into electronics or something

300ZX (Z31) Forums Dedicated to 84-89 ZCars otherwize known as the Z31's

When it rains...seems water gets into electronics or something

Reply

 
 
 
Old 09-13-2018, 10:20 PM
  #1  
Registered User
Thread Starter
 
Donn144's Avatar
 
Join Date: Jan 2014
Posts: 241
When it rains...seems water gets into electronics or something

1987 300ZX
Whenever it rained hard my Z would run VERY rough. I had the cables replaced with a tuneup and this helped A LOT! But, still after a hard rain it will take 15-30 seconds of running to run smoothly. BUT this weekend she sat for 3-4 days and it had rained..today even after 30 minutes she ran like she was missing a cylinder i.e not firing. I thought the coil or AFM took a hit. But, she sat warmed up from my drive and later in the day right when I was about to test the AFM, she ran smooth. Seems the water dried out.

QUESTION: Where is the water getting in from? And, what is it dampening ?

Thx for any ideas

Donn
Donn144 is offline  
Reply With Quote
Old 09-14-2018, 10:07 AM
  #2  
Registered User
 
Join Date: Nov 2013
Location: east KS
Posts: 284
Mass meters act up on damp weather , the sensor a 900 degree nichrome wire cools as the air passes by , throw in moisture and it cools extremely and can flood then the O2 shuts down FI
also it can get to the circuit boards
86tcoupe is offline  
Reply With Quote
Old 09-14-2018, 10:52 AM
  #3  
Registered User
Thread Starter
 
Donn144's Avatar
 
Join Date: Jan 2014
Posts: 241
OK ..did not happen with my 88 all those years. Would changing the AFM out make any difference..or I just have deal with it?
Covering car when it rains? Unfortunately, no garage available.

Thx for the input!

Donn
Donn144 is offline  
Reply With Quote
Old 09-14-2018, 01:54 PM
  #4  
Registered User
 
Gentleman Z's Avatar
 
Join Date: Sep 2018
Location: Georgia
Posts: 5
Misfire when raining/damp

I too have this problem on my Ď85. I believe it is the distributor cap/ rotor. I also have heard if your wires/plugs arenít NGK then it can cause this as well. Iíve got both the plugs and the wires on order now and am going to replace the distributor cap and rotor as well. I will let you know if this fixes anything. My misfire lasts about 10-15 minutes and then quits so it does not last nearly as long as yours. Let me know if you find a solution.

Gentleman Z is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
snwbrderphat540
The Lounge (Off Topic)
8
04-11-2007 02:47 PM
skittle
240Z, 260Z, 280Z (S30) Forums
15
02-27-2007 12:17 AM
z-hag
300ZX (Z31) Performance / Technical
4
10-11-2006 12:00 PM
1SIKZ
300ZX (Z32) Appearance Exterior, Interior
1
05-17-2006 08:18 AM
goldenchild7801
FS: 240Z,260Z,280Z & 280ZX (70-83)
0
11-21-2005 11:45 AM


Thread Tools
Search this Thread