300ZX (Z31) Performance / Technical Discussions related to Turbo charging, Supercharging, Engine, ECU, exhaust, and etc. performance enhancements and Techical related.

Idling Problem

Old 05-30-2018, 11:37 PM
  #1  
Registered User
Thread Starter
 
Join Date: Mar 2018
Posts: 1
Idling Problem

so I have an 84 Turbo 50th anniversary edition, and it idles SUPER rich (chugging gas) and really high 1300rpm at cold start, then at 16-1700rpm as it gets warm. Iíve tried a bunch of tests like the Maf and such, anyways I unplugged the first fuel injector connector, and the car ran from 1700 to 1200 rpm. I thought taking out a fuel injector made the car run worse? And if anyone has any tips about the rich running and high idle please Iím all for it!!
Zinger_30 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
The300zxDude
300ZX (Z32) Performance / Technical
0
04-01-2016 05:04 PM
dwende170
300ZX (Z32) Performance / Technical
1
03-11-2004 05:24 PM
zryde
300ZX (Z31) Forums
10
06-08-2003 12:10 PM
jonnyz
300ZX (Z32) Performance / Technical
4
04-23-2003 05:36 PM
Brandar77
240Z, 260Z, 280Z (S30) Forums
8
12-10-2002 10:17 AM


Thread Tools
Search this Thread
Quick Reply: Idling Problem


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.