300ZX (Z31) Performance / Technical Discussions related to Turbo charging, Supercharging, Engine, ECU, exhaust, and etc. performance enhancements and Techical related.

Digital dash not working

Old 02-21-2016, 03:49 PM
  #1  
Registered User
Thread Starter
 
Join Date: Feb 2016
Posts: 2
Digital dash not working

Hey guys, just picked up my first Z. Digital dash not working as far as speedo, tach, or any other vital gauges. However, headlight, tail light, turn signal, cruise control lights come on with no problem. Wondering if anyone else have had similar problems before I start poking around aimlessly at fuses for hours on end? Pertaining to an 85 z31. Thanks!
Kyle_holland is offline  
Old 02-21-2016, 05:52 PM
  #2  
Grumpy & Helpful
 
Join Date: Sep 2006
Location: Mill Creek WA
Posts: 1,415
could be the power supply is shot but get out the vom and check the fuses and the fusible links. none of the stuff that works has any bearing on the digi dash display.
rogerz is offline  
Old 05-10-2016, 04:18 PM
  #3  
Registered User
 
Join Date: May 2016
Posts: 7
trophy235 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
19872plus2
Wanted (WTB / WTT)
1
09-28-2013 05:05 PM
turbotim
300ZX (Z31) Performance / Technical
2
05-04-2013 04:28 PM
Zed59
280ZX Appearance Exterior, Interior
5
07-25-2010 06:47 AM
Roach
280ZX Performance / Technical
0
05-21-2010 10:17 AM
cortinasiv
300ZX (Z31) Forums
1
11-28-2009 06:45 AM


Thread Tools
Search this Thread
Quick Reply: Digital dash not working


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.