240Z, 260Z, 280Z Performance / Technical Discussions related to performance motor enhancements, upgrades.

Idle problem on '82 280zx

Old 06-20-2012, 06:10 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jun 2012
Posts: 1
Idle problem on '82 280zx

Please excuse me if this was answered somewhere else... I looked, but didn's really find an answer to this-

'82 280ZX, Non Turbo with 81k miles, 5 speed.

Starts fine, idles high (not excessive) then settles down. After it warms up, I noticed that the RPM's fluctuate up and down, sometimes almost to stalling and sometimes just stalls. It starts right back up, but will continue that symptom. It's really noticable if I give a little gas or if I drive it around the block. The gas is old, but I assumed that if it was crummy fuel, it would idle rough no matter when.

Also, when I give it gas, it seems to hessitate a little before taking off, and just feels like it lacking the "umph" that it had.

Any suggestions would be appreciated!!!

Thanks in advance.
motormark is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fanglord
300ZX (Z31) Forums
9
06-08-2014 09:02 PM
Z Pal
300ZX (Z31) Forums
8
02-27-2014 08:50 PM
Crusty_Lips
280ZX (S130) Forums
1
08-14-2013 07:20 AM
nismodrifterx
300ZX (Z32) Forums
1
08-19-2011 03:37 PM
deckart
300ZX (Z32) Forums
3
11-27-2002 04:20 AM


Thread Tools
Search this Thread
Quick Reply: Idle problem on '82 280zx


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.